What are the requirements?

The minimum requirements are: Joomla 3, PHP 5.6 and newer, and MySQL 5.1 and newer at the time of writing this article.